StudyTeam for Sites User Administration

Incident Report for StudyTeam

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 12:02 UTC

Identified

StudyTeam for Sites is currently experiencing issues with our **StudyTeam Site Administration** functionality. If you are a User Admin, you may not be able to add new users, or you may not find the StudyTeam Site Administration option in your dropdown. We are aware of this issue and are working on it diligently.
If you have any questions or concerns, please contact Support.
Posted Jun 27, 2025 - 02:19 UTC
This incident affected: SITE (US Site Prod, AP Site Prod, AU Site Prod, CA Site Prod, CN Site Prod, EU Site Prod, BR Site Prod).