Adding New Trials to Existing Patients Erroring

Incident Report for StudyTeam

Resolved

This incident has been resolved
Posted Jun 05, 2025 - 18:29 UTC

Investigating

We are investigating a short term error preventing the addition of trials to existing patients. This had a duration of approximately 20 minutes.
Posted Jun 05, 2025 - 18:02 UTC
This incident affected: SITE (US Site Prod).