Potential Data Delays in Sponsor Reporting

Incident Report for StudyTeam

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 18:39 UTC

Investigating

We are currently investigating a potential delay in data refresh in StudyTeam for Sponsors.
Posted Jun 09, 2025 - 14:29 UTC
This incident affected: US Sponsor Prod.