Patient Searching Not Returning Some Patients

Incident Report for StudyTeam

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 23:27 UTC

Investigating

We are currently investigating an issue causing some patients to not return when searched & not show in the Patients tab.
Posted Nov 06, 2025 - 22:37 UTC
This incident affected: SITE (US Site Prod, AP Site Prod, AU Site Prod, CA Site Prod, CN Site Prod, EU Site Prod, BR Site Prod).